pump issues!! major headache today

Discussion in 'Water Fed Pole Cleaning' started by colinvansmith, Oct 18, 2011.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. I have a sureflo pump with digistream controller, today whilst working the controller and pump just turned off for no reason. Then when i went to turn it back on it wouldnt turn on i waited about 20 minutes then it turned on. started cleaning a gain and when i detatched the wfp and it was reading dead end it turned off again same thing but had to wait 30 mins before it would come back on, then same thing happened twice more and i'd had enough for the day. its a new battery all the connections seem to be fine and the pump and controller seem to work fine when on. This keeps happening when the system comes up with a dead end but usually a dead end is fine for example its dead ended when i go from the front to the back of the house etc and no issues in the past with doing that. On one occasion today as i was walking back to van it was flashing the warning pressure switch but again no issues with that in the past. Can anyone shed any light on this situation its driving me insane there doesnt seem to be much of a pattern to it so i can't work out where the issue is.
  2. Hinty

    Hinty Well-Known Member

    Mar 12, 2011
    Likes Received:
    Hi Col.
    Could it be a sticking pressure switch?
    Might be worth taking both connectors off the pressure switch and joining them together to see if it helps.

    Alternatively it could also be a dry solder joint on the circuit board - if it is out of warranty you could open it up and see if there are any cracks in the solder that may be breaking the circuit when they get hot, an re making the circuit when they cool.

    These problems are so annoying, hope you get it sorted soon
  3. Finally got to the bottom of it, dodgy soldering in my flow controller grrr!!