Purefreedom Van Install Problems

Discussion in 'Water Fed Pole Cleaning' started by MyLittleCleaningCompany, Jul 24, 2012.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. I was wondering if anyone else has had an issues with their Purefreedom wfp install? I am yet having another morning sorting out problems due to another hose splitting! I've only had my system just over 4 months and probably only fill the tank (350l) 2-3 times a week. So far I have had the external van port connectors replaced as they were leaking and draining the tank, the clear hose that connects my reel to the van replaced due to it splitting whilst out working forcing me to stop for that day and the next. The booster pump had to be sent back as it was loosing pressure, I lost a mornings work whilst the van filled up (I normally do this in the morning before work), Pump 1 of 2 making a high pitch squealing noise and then looses pressure. I have had leaks coming from the water softener unit that I have had to fix and now this morning a so called "high pressure hose" on the booster pump has split causing a nice big puddle on my van floor. I paid a fair bit of money to have a "professional" install but all I seem to have is poor quality materials and rubbish workmanship and all Purefreedom keep saying is "this is very unusual" and "this has never happened before" so if anyone has had any issues I would love to hear them so I can feel I'm not the only unlucky one!!
  2. daley

    daley Banned

    May 30, 2012
    Likes Received:
    the hose is **** i got troly iv got washing macen hose ,the srtaner that gos in barall fell off ,the hoselock ,tiyp, is **** ,the handall lock brock off and the welding brok in two places ,im two far a way to take back :huh: