Jump to content







Before posting a new topic please use the search feature. Duplicate posts may be removed or merged with others.

Start new topic


bluemoon

Leaks!

Recommended Posts

bluemoon

Hi all and hope one of you can help.

 

I've got a Shurflo 100psi and the 2 elbow connectors that came with it. The problem is that it has now started leaking on the outlet joint, but only when i've got the tap on my pole turned of to stop the water as the pressure causes it to leak.

The water sprays out under pressure in a small jet where the hose connects. I've got a jubilee clip and wound bit ptfe tape round the elbow connection and have tried using fernox silicone sealer thingy.No luck and it keeps leaking which is very annoying as can't turn tap off and ends up soaking my van and sure it doesn't help my pump as it never shuts off as it never reaches cut out point for varistream controller and seems to loose pressure throughout the day.

 

Hope i explained this clearly and hope someone can suggest best way to connect so it stops leaks.

 

Thanks

Share this post


Link to post
Guest OoO

Have you tried lowering the dead end stop setting for it.

 

Maybe it's too high?

Share this post


Link to post
bluemoon

Damo sorry to sound stupid but whats that and how do i do it?

Share this post


Link to post
Guest OoO

Is it digital yeah?

Share this post


Link to post
bluemoon

yeah damo it the digi one the VSD6

Share this post


Link to post
bluemoon

so i need to lower it go from C to D or E??

Share this post


Link to post
Guest OoO

Don't know mate. You could try lowering it to B

 

IT depends on your system mate.

 

Worth a try. When your tap is closed how long does it take to hit the P or DE IE the pump stops.

Share this post


Link to post
mark m

for some reason the picture is upside down so stand on your head lol I have shown there is two ways you can connect your pump one is ptfe jubilee clip the other is hozelock style fittings

5915c9e5cd4af_securedownload(14).jpg.26691e2dd3258980a627dbff61d4298e.jpg

Share this post


Link to post
Tuffers

Gas tape is a good sealer, it's thicker than PTFE tape.

Share this post


Link to post
bluemoon

I have tried the ptfe tape and still leaks. Damo my pump rarely if ever shuts off as the leak lets all the pressure escape. If it does shut off then it takes a good minute or two.

 

Mark how did you connect the hoselock tap connector to the pump, what piece do i need to fit onto the pump?

 

Thanks for the replies everyone.

Share this post


Link to post
bluemoon

thanks Mark i'll try that out and see how it gets on. So annoying with the leak issue just need it sorted and my system will be running perfectly. thanks

Share this post


Link to post
Guest OoO

Sounds like its set too high then really. Worth dropping down to b or a

Share this post


Link to post
bluemoon

 

for some reason the picture is upside down so stand on your head lol I have shown there is two ways you can connect your pump one is ptfe jubilee clip the other is hozelock style fittings

 

Thanks Mark!!!!! Just tried this out and the leak is cured and pump now shuts off!!!! Gotta run it for a few days to see if it holds up but think it will do. Thanks again buddy, really appreciate the help

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.