Backpack Help!

Discussion in 'Water Fed Pole Cleaning' started by C-THROUGH, Aug 4, 2013.

Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. C-THROUGH

    C-THROUGH Active Member
    Member

    Joined:
    Apr 22, 2012
    Messages:
    233
    Likes Received:
    4
    I bought the wcw backpack last week but still can not get it to work.
    The water comes out of the outlet but when I connect the pole up NOTHING!!!!!!!
    Any help would be appreciated!!
    AAAAARRRRRGGGGGHHHHHHHHH!!
    I am sure I am just being thick but..........
     
    Advertisement
  2. OoO

    OoO Guest

    Well what connectors are you using, maybe an end stop is stopping the water?
     
  3. steele

    steele Well-Known Member
    Member

    Joined:
    Jul 1, 2013
    Messages:
    273
    Likes Received:
    41
    Post pics of setup. Think it'll help diagnose the problem
     
  4. C-THROUGH

    C-THROUGH Active Member
    Member

    Joined:
    Apr 22, 2012
    Messages:
    233
    Likes Received:
    4
    Steele I cant post pics of set up sorry cos honest I am the worst person for technology ever!
    I can only just get on this forum.
    But thanks for reply.
    Extreme Damo: What is an end stop?
    What connector should I use?
     
  5. OoO

    OoO Guest

    It could be a million things.

    What happens when you connect the Poe hose? What on the end of the pole hose? Is there a fitting?
     
  6. Posh

    Posh Hero
    Member

    Joined:
    Jan 8, 2012
    Messages:
    5,902
    Likes Received:
    954
    I have a female hozlelock connection on my wcw backpack. A male hozlelock connection with a 6mm tail of which my 8mm hose is connected to which in turn connects to my brush via push connectors.

    Have you got the flow turned up enough.
    Are your jets blocked.
    Have you tried it through the hose before it hits the brush.
    If yer using hozlelock connection it isn't getting stuck to stop water coming out
    Also I was told to charge mine for 24 hours before using.

    Mine when I first got it leaked. Wcw delivered a new one the next day & took faulty one back.
    Great service.
     
  7. tench0771

    tench0771 Grand Master
    Member

    Joined:
    Jun 30, 2013
    Messages:
    4,284
    Likes Received:
    932
    try blowing throu the pole hose if u can then trun ur flow rite up on bk pak if still not wrking ide say u have a duf hoselock if that the case send it bk thay should send u a nother 3 of charge .
     
  8. ACW

    ACW Member
    Member

    Joined:
    Jun 9, 2013
    Messages:
    87
    Likes Received:
    0
    If its one of those self shut off connectors try switching to a plain one.
     
  9. Bingo

    Bingo Grand Master
    Member

    Joined:
    Aug 22, 2012
    Messages:
    3,793
    Likes Received:
    424
     
Advertisement