Has this ever?????

Discussion in 'Water Fed Pole Cleaning' started by ALPINEYORKS, Feb 12, 2015.

Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. ALPINEYORKS

    ALPINEYORKS Active Member
    Member

    Joined:
    Mar 22, 2012
    Messages:
    170
    Likes Received:
    12
    Hi there. My ro system had started to produce water really slow but the quality of the water was still a good low ppm. After inspecting my system I have noticed that the last pre filter which I believe is the charcoal one has failed allowing the charcoal to flow through and then block my first ro membrane. is this a common thing to happen? First time for me in 7 years but my question is does an ro pump help cause this has I fitted the pump at the same time as the last membraines so after replacing the membraines I'm unsure wheather or not to turn it on.
     
    Advertisement
  2. abs

    abs Guru
    Member

    Joined:
    Jun 4, 2014
    Messages:
    1,379
    Likes Received:
    441
    The carbon filter does get bits on it, suppose it could clog up the system , won't hurt to turn the booster pump on it may even push the blockage out ?? Or make it worse:thumbsdown:
     
  3. Smurf

    Smurf Banned
    Member

    Joined:
    Mar 18, 2012
    Messages:
    20,811
    Likes Received:
    3,812
    I'm not sure what psi/flow those carbon cartridges are rated at but the only thing stopping the carbon granules coming out and being pushed into the membrane is a thin filter that has obviously failed.

    What psi is the pump and what make is the carbon cartridge?

    Reason why I’m asking if the carbon cartridge is within normal working spec you could complain to the supplier and try to get them to pay for replacement membranes as they are obviously fooked now.
     
  4. ALPINEYORKS

    ALPINEYORKS Active Member
    Member

    Joined:
    Mar 22, 2012
    Messages:
    170
    Likes Received:
    12
    To be honest I think it's just a poor cartridge don't know the make of it. The membraines are amfor though. I have the pump set up straight after the charcoal so thinking about it should this cause them to break. I've stopped using the pump for now may just use it when I'm in a desperate need for water
     
  5. spruce

    spruce Grand Master
    Member

    Joined:
    Jun 4, 2012
    Messages:
    2,534
    Likes Received:
    734
    .....or put the booster pump after the prefilters and before the membrane. I think this is the way Purefreedom set their 4040's up.
     
  6. ALPINEYORKS

    ALPINEYORKS Active Member
    Member

    Joined:
    Mar 22, 2012
    Messages:
    170
    Likes Received:
    12
    That's the way it is already mate. But I'm think would it draw the water out quicker hence why it's split. God knows. Just another annoying WFP problem
     
  7. spruce

    spruce Grand Master
    Member

    Joined:
    Jun 4, 2012
    Messages:
    2,534
    Likes Received:
    734
    I would change from a granular carbon filter to a Fiberdyne carbon filter TBH. The only thing holding those granules back is a thin gauge type material and/or a bit of sponge.

    I've just looked at an old one I had lying around.
     
  8. ALPINEYORKS

    ALPINEYORKS Active Member
    Member

    Joined:
    Mar 22, 2012
    Messages:
    170
    Likes Received:
    12
    Do you have a link to view one of these mate?
     
  9. Smurf

    Smurf Banned
    Member

    Joined:
    Mar 18, 2012
    Messages:
    20,811
    Likes Received:
    3,812
  10. Smurf

    Smurf Banned
    Member

    Joined:
    Mar 18, 2012
    Messages:
    20,811
    Likes Received:
    3,812
Advertisement