My Slx 35 Is Spinning!

Discussion in 'Water Fed Pole Cleaning' started by Neil, Oct 17, 2013.

Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. Neil

    Neil Grand Master
    Member

    Joined:
    Apr 30, 2012
    Messages:
    3,750
    Likes Received:
    354
    When I was using it today it started spinning so I tightened up the clamp that I thought would sort the problem but didn't change anything, it keeps spinning and It looks like it has a sleeve inside that it slides out of does anyone know how or if it can be fixed ? I treat my poles with respect why does this have to happen
     
    Advertisement
  2. tench0771

    tench0771 Grand Master
    Member

    Joined:
    Jun 30, 2013
    Messages:
    4,278
    Likes Received:
    932
    wat clamps u got on slx neil old ones or new smart clamps ??
     
  3. Neil

    Neil Grand Master
    Member

    Joined:
    Apr 30, 2012
    Messages:
    3,750
    Likes Received:
    354
    Hello mate, I've got the new ones mate
     
  4. tench0771

    tench0771 Grand Master
    Member

    Joined:
    Jun 30, 2013
    Messages:
    4,278
    Likes Received:
    932
    i thalt u could crank them clamps rite up im shore alex said they cant b over titend ide try twisting them more the clamp could b falty ive never used smart clamps only old ones im shore alex could shed some lite
     
  5. Neil

    Neil Grand Master
    Member

    Joined:
    Apr 30, 2012
    Messages:
    3,750
    Likes Received:
    354
    The thing is I did tighten it up and I could just pull the section out which is weird !
     
  6. tench0771

    tench0771 Grand Master
    Member

    Joined:
    Jun 30, 2013
    Messages:
    4,278
    Likes Received:
    932
    sounds like the clamp is nackerd m8 how old is the pole is it just one section spinning ?
     
  7. Neil

    Neil Grand Master
    Member

    Joined:
    Apr 30, 2012
    Messages:
    3,750
    Likes Received:
    354
    The pole is about 3months old, and it's just the one section if I can remember it was the 2nd section that is spinning
     
  8. tench0771

    tench0771 Grand Master
    Member

    Joined:
    Jun 30, 2013
    Messages:
    4,278
    Likes Received:
    932
    best thing to do m8 is pm alex an send pole bk he will sort it out pronto gardeners custmer service is ace, i never liked the clamps on my clx they spun an needed adjusting all the time so i went 4 a facelift an its bin spot on no spinning at all an very fast to use the slx is a cracking pole but the clamps let it down just my view tho my super max is the same luv the pole not keen on the clamps hope u get it sorted m8
     
  9. David Taylor

    David Taylor Well-Known Member
    Member

    Joined:
    Sep 11, 2012
    Messages:
    619
    Likes Received:
    30
    To me it sounds like the clamp body has become unglued from the section. All you need is some strong epoxy glue from halfords or some other store.

    Clean all the old glue off from the section and the inside of the clamp body and it will be good as new.
     
  10. Alex Gardiner

    Alex Gardiner Forum Addict
    Supplier

    Joined:
    Mar 1, 2012
    Messages:
    697
    Likes Received:
    233
    Hi Neil

    It sounds like you have a clamp that has come loose. If you have a look at it can you pull the clamp upwards off the tube section?

    Can you send me an email with your name and order number or date of purchase and we can look at this for you.
     
Advertisement