New RO high TDS!!

Discussion in 'Water Fed Pole Cleaning' started by Squeegee1, Aug 11, 2015.

Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. Squeegee1

    Squeegee1 Newcomer
    Member

    Joined:
    Feb 19, 2015
    Messages:
    24
    Likes Received:
    2
    Good evening people, have a problem that's driving me crazy and any advice would be very very welcome. The unit is from RO Man and mains water reading is 329. After running system for a few days it's still at 100. Have di vessel on van but was hoping for a much lower reading any ideas? Water pressure is 65 psi. :)
     
    Advertisement
  2. joe34

    joe34 Well-Known Member
    Member

    Joined:
    Feb 10, 2013
    Messages:
    269
    Likes Received:
    10
    Had the same problem a few weeks ago after going through a new 40 40 ro it was still 80ppm, tap water was 400 plus. whats your pressure like where you are? And is it the same make ro you had before ?

    I needed a ultra low ro as the first one I had was still producing high ppm after going through it.

    I was driving me nuts wondering why it wasn't working properly.
     
  3. joe34

    joe34 Well-Known Member
    Member

    Joined:
    Feb 10, 2013
    Messages:
    269
    Likes Received:
    10
    Sorry just read your post all the way through 65psi is the ro low pressure?
     
  4. doug atkinson

    doug atkinson Well-Known Member
    Member

    Joined:
    Jul 12, 2012
    Messages:
    559
    Likes Received:
    54
    Contact RO Man as straight away he will know what the problem is
     
  5. Squeegee1

    Squeegee1 Newcomer
    Member

    Joined:
    Feb 19, 2015
    Messages:
    24
    Likes Received:
    2
    Thanks lads will ring this morning
     
  6. Alien Human

    Member

    Joined:
    Mar 15, 2015
    Messages:
    1,035
    Likes Received:
    339
    In my experience it's often just small tweeks that need making (which is hopefully good news)

    I put the hosepipes in the wrong way in my twin DI vessels the other day e.g out to out & in to in and when things didn't then work 'smoothly' I proceeded to curse the vessels, the company, my van, life, the universe and all of the gods for a good 20mins.........until I realised the genius mistake that I had made.
     
  7. Squeegee1

    Squeegee1 Newcomer
    Member

    Joined:
    Feb 19, 2015
    Messages:
    24
    Likes Received:
    2
    Sounds very familiar Alien.:)
     
Advertisement