Pct Volton Split Charge Relay Problem

Discussion in 'Water Fed Pole Cleaning' started by nwcs, Jan 31, 2013.

Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. nwcs

    nwcs Forum Addict
    Member

    Joined:
    Jan 19, 2013
    Messages:
    742
    Likes Received:
    29
    hi all

    wonder if someone could help me

    i use a pct volton split charge relay in my van

    been working fine and i can here it clicking on when i start my van and when i stop engine it click back off

    last week battery died on me.

    had a play about and found when i start van i here it click on but then it clicks back off, then as im driving round it keeps clicking on then off over and over.

    can any one help

    the permenant live out put is live so its still getting power.
     

    Attached Files:

    Advertisement
  2. spruce

    spruce Grand Master
    Member

    Joined:
    Jun 4, 2012
    Messages:
    2,541
    Likes Received:
    737
    I've never seen one so I can't help. It sounds as though the unit is reading an incorrect voltage.

    We had a similar thing happen to our Brocott SCR and they have an adjusting screw on the side which can be adjusted by a small flat screwdriver.
    (I would imagine each one of these will have an adjuster as it would be impossible to make an electronic C/B to be that accurate for the cost.) If it isn't visible from outside then maybe you can look inside. I checked to make sure of the position on the screw before I started any adjustments.

    I found on the last one that it must have had a bit of corrosion on the contacts of the adjuster as a quick couple of small turns back and forward solved the problem when the adjuster was returned to its original position.

    Hope that helps
     
  3. nwcs

    nwcs Forum Addict
    Member

    Joined:
    Jan 19, 2013
    Messages:
    742
    Likes Received:
    29
    Hi thanks for the replie. Yes mine has the ajuster but never moved it. Will have a go in morning and see of that sorts it out. These units are only £8:00 so cant see them lasting forever
     
  4. bluemonkey

    bluemonkey Guru
    Member

    Joined:
    Apr 25, 2011
    Messages:
    1,134
    Likes Received:
    28
    by pass it and wire pos to pos with a fuse in the middle
     
  5. nwcs

    nwcs Forum Addict
    Member

    Joined:
    Jan 19, 2013
    Messages:
    742
    Likes Received:
    29
    just an update go let you know it was the battery... fitted new battery and it works fine now
     
  6. spruce

    spruce Grand Master
    Member

    Joined:
    Jun 4, 2012
    Messages:
    2,541
    Likes Received:
    737
    Thanks for the update. Not sure why this would cause the problem TBH but will put it into the 'experience box.'
     
  7. nwcs

    nwcs Forum Addict
    Member

    Joined:
    Jan 19, 2013
    Messages:
    742
    Likes Received:
    29
    there must of been a dead cell that was causing the battery to still work but split charge relay must of detected the short, so as it was clicking on it then clicked back off for safty reasons

     
  8. bluemonkey

    bluemonkey Guru
    Member

    Joined:
    Apr 25, 2011
    Messages:
    1,134
    Likes Received:
    28
    if a battery is knackered, it some times over loads the charger and pulls too much and sometimes blows it
     
Advertisement