Pure Freedom Booster

Discussion in 'Chit Chat & Introductions' started by Matty H, May 28, 2012.

Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. Matty H

    Matty H Forum Addict
    Member

    Joined:
    Jan 23, 2012
    Messages:
    864
    Likes Received:
    24
    I filled my van Saturday all fine. Got home today to fill connected it all up but when I switched the booster on - NOTHING :mad:

    It was making the buzzing noise so I knew power was getting to it - I also knew water was flowing through it as it was reading on the gauge. But it didn't start whirring and pumping the water. Only had it fitted a few months ago - not happy as i can't fill my van now. I'm onto the phone to them first thing tomorrow. Anybody else had a prob with these boosters? It's not one on their website it's a heavy duty one that's mounted inside the van
     
    Advertisement
  2. Mate so strange you have gone through this. I brought mine just over 2 months ago and hadn't had any problems till last Thursday morning when I tried to fill up. The pump was making a really noisy buzzing noise. I was still getting water but the pressure dropped from 120 to 60 psi. I tried turning it down then back up again but nothing worked. When turning off my water pressure was still 30 psi from the tap which according to the company that makes them that should be fine. Long story short a courier collected the brass part on Friday and they sent out a blue connecting tube so I'm filling up slow time at the mo. Hopefully should here back from them tomorrow.
    [hr]
    Can't you just turn the red tap to close and fill up without it on. Should be fine.
     
  3. Matty H

    Matty H Forum Addict
    Member

    Joined:
    Jan 23, 2012
    Messages:
    864
    Likes Received:
    24
    I can't even bypass the booster and fill without as they have plumbed the hoses from the booster directly to the RO. I am totally unable to fill my van until its fixed. I hope they can sort it tomorrow :D
     
  4. Mines got to be the same mate I can't see why they would do it different. Do you not start to fill then turn plug in your pump?
    [hr]
    Take out "turn"
     
  5. Matty H

    Matty H Forum Addict
    Member

    Joined:
    Jan 23, 2012
    Messages:
    864
    Likes Received:
    24
    Yes sounds the same - do you have a tap valve fitted To your RO?
     
  6. Yes, to open the RO and flush it. I also have a red tap to adjust the pump pressure. You should be able to operate your system without the pump just using the pressure from the tap. It will take a lot longer. My 350l takes 6-7 hours instead of the 1 to fill! If you get it on now you might be able to get some work done. :D
     
  7. 1stopcleaning+maintenance

    Member

    Joined:
    May 19, 2012
    Messages:
    88
    Likes Received:
    0
    fellas how do you connect the booster pump to your filter/r.o system, iv gotta get 1 takes all nite to fill my 400 l drum at min, thing is i dont know where or how to work/connect the booster when it arrives
    [hr]
    .. any chance of any picture of your system how it connects and all that ? many thanks steve
     
Advertisement