Pure freedom trolley problem.

Discussion in 'Water Fed Pole Cleaning' started by Squeegee1, Aug 5, 2015.

Advertisement
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to the UK Window Cleaning Forums.
    Starting or own a window cleaning business? We're a network of window cleaners sharing advice, tips & experience. Rounds for sale & more. Join us today!

  1. Squeegee1

    Squeegee1 Newcomer
    Member

    Joined:
    Feb 19, 2015
    Messages:
    24
    Likes Received:
    2
    Gd evening peeps. Wondered if any of you may be able to point me in the correct direction.
    brought a van with pure freedom set up, everything works fine except the trolley. Put it on charge and green light comes on to say fully charged but when disconnected. It says 0 on bat function.even when left on charge for hours. Help anyone have any ideas. System only 4 months old.
     
    Advertisement
  2. Squeegee1

    Squeegee1 Newcomer
    Member

    Joined:
    Feb 19, 2015
    Messages:
    24
    Likes Received:
    2
     
  3. Squeegee1

    Squeegee1 Newcomer
    Member

    Joined:
    Feb 19, 2015
    Messages:
    24
    Likes Received:
    2
    System was installed by previous owner
     
  4. Tuffers

    Tuffers Hero
    Member

    Joined:
    Sep 10, 2012
    Messages:
    9,393
    Likes Received:
    2,745
    Sounds like a duff battery.
     
  5. Squeegee1

    Squeegee1 Newcomer
    Member

    Joined:
    Feb 19, 2015
    Messages:
    24
    Likes Received:
    2
    Oh not good worser if previous owner would still have it covered under warranty
     
Advertisement