Jump to content
J D

FAO Alex. New SLX Clamps!

Recommended Posts

J D

Dont have my slx 18 very long and i dont use it that often, as my current slx is still in one piece. Already the end section has got the dreaded spin disease! Its got the new clamps fitted as well ! Im so annoyed about this, really thought this new Gardiners clamp system had solved this horrible problem!

Maybe ive just been unlucky? Anyone else having problems?

Share this post


Link to post
TJTOPCAT

I thought the new gardiners clamps are self adjusting.??

Tighten them up enough to be able to extend each section without to much resistance.

You do need to tighten them up enough to stop the pole sections twisting though.

Share this post


Link to post
SPCleaning

Mine seems to 'get loose' again. I tighten the little wing nut but very soon the pole will spin if I am using it sideways on. (If you know what I mean)

Share this post


Link to post
J D

I know where your coming from fellas. However i cant physically tighten it any further or ill crack the section! Its as tight as it will go!

Share this post


Link to post
♠Winp®oClean♠

It might be worth checking to see if the threaded bar is screwed fully into the cylindrical retainer on the cam part of the clamp, as if not the clamp may not close as it is supposed to do giving the problem you describe. The nut might be fully threaded in but the bar not meaning the clamp can't close any tighter. You might want to remove the nut & try screwing the bar further in with some pliers.

Share this post


Link to post
SPCleaning

I might look at that tomorrow. I am never sure how much pressure should be applied to the lever to close it and lock the pole into place. I am afraid to tighten it too much in case I damage the thing.

Share this post


Link to post
Alex Gardiner

Hi JD

 

How old is the pole?

 

Best thing to do is to contact us with the purchase date and some detailed photos of the affected part. It would be very surprising for one of our new poles to be spinning if fitted with Smart Clamps.

Share this post


Link to post
Alex Gardiner

Sounds like you need some new locking nuts. If the pole is under 12 months old get in contact and we can sort this out for you.

Share this post


Link to post
J D

Hi Alex. It was purchased via surecleansystems on Sept 10th 2014. As for pictures, everything looks fine, no physical looking wear on the problem clamp. Its just not possible to tighten anymore and the section spins!

Share this post


Link to post
Alex Gardiner
Hi Alex. It was purchased via surecleansystems on Sept 10th 2014. As for pictures, everything looks fine, no physical looking wear on the problem clamp. Its just not possible to tighten anymore and the section spins!

 

Hi JD

 

Could you email me several clear photos of the clamp when open, closed and the section clamping on to so that I can check it over?

 

alex@agardiner.co.uk

Share this post


Link to post
SPCleaning

So @Alex Gardiner is it usual for the little nuts to keep getting loose? I tighten them 3 or 4 times a day? I had the pole on 9th January 15

Share this post


Link to post
Alex Gardiner
So @Alex Gardiner is it usual for the little nuts to keep getting loose? I tighten them 3 or 4 times a day? I had the pole on 9th January 15

 

No this is not usual. Drop me an email and I can look at getting this sorted for you.

Share this post


Link to post
J D
Hi JD

 

Could you email me several clear photos of the clamp when open, closed and the section clamping on to so that I can check it over?

 

alex@agardiner.co.uk

 

I will do tomorrow Alex. Thank you

Share this post


Link to post
J D

Alex. I took the pliers to the problem clamp one more time today, before uploading any pics. I heard a little click and i was able to tighten the clamp just enough for it to take hold again on section. Im thinking a little bit of grit in the clamp mechanism was stopping me from tightening it ! All a learning curve i suppose & spinning disaster averted. Thanks for your help as always.....

Share this post


Link to post
SPCleaning

Thank you @Alex Gardiner for sending out replacement locking nuts. Speedy service as always. I just wasn't quite so speedy in thanking you.

Share this post


Link to post
ALPINEYORKS

Got to say thanks Alex. Top service from your company's rexieved poles today. Spot on don't know why I didn't make the decision to swap years ago. Thanks

Share this post


Link to post
Tuffers

I find that sometimes the thread needs lubricating to allow you to tighten the clamp more. Also, this is probably the wrong way to do it, but if the clamp is stiff, I sometimes tighten by turning the thumb lock rather than the nut part, it's easier to tighten that way.

Share this post


Link to post
tench0771

my clamp nuts do wrk lose but i only need to readjust them like 2 or 3 times a week no biggy realy the nuts have a cheepy fiel to them but ide rather there adjustable then to stiff to adjust when needed

Share this post


Link to post
Barney

When I first got my slx-30. I had a bit of spin, but I've just tighened the nuts quite tight and I havn't had to adjust them for months. Great bit of kit.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.