Jump to content
Tim Osborne

Excelerator Handle

Recommended Posts

Tim Osborne

I have been using the Excelerator for a few weeks and already the channel (liquidator 2) slides around very easily in the handle. Does anyone else find that this is happening?

 

It seems the spring inside is not strong enough on mine. Maybe its defective??

Share this post


Link to post
Eric Gilliand

No issues with either my prototype or the production model. Obviously a sharp knock or drop will cause movement but in general use, no.

Share this post


Link to post
stevethewindowcleaner

I've had the rubber sliding a bit a few times and I've only had it a couple of days.

Share this post


Link to post
Nick pegler DWC

I have found the channel moving on both handles just like combnatior will we ever find the perfect squgee. ..

Share this post


Link to post
Eric Gilliand
I have found the channel moving on both handles just like combnatior will we ever find the perfect squgee. ..

Strange... I have no issues with the bi-component handle, the black handle or either of my Excelerators... obviously if I bang it, or drop it, there is some movement, but in general use, no.

Share this post


Link to post
James Allen
I've had the rubber sliding a bit a few times and I've only had it a couple of days.

Get your self a paper clip and cut about a cm and stick it in the clip at the bulge and it stops the rubber moving and keeps it tight

Share this post


Link to post
Tim Osborne
No issues with either my prototype or the production model. Obviously a sharp knock or drop will cause movement but in general use, no.

 

Not dropped it yet but I do use it with the FLIQ pad and have noticed the rubber and channel have moved quite a bit after using the FLIQ. Don't get me wrong, I love this squeegee it is by far the best yet but I am a bit concerned with the movement of the channel and rubber after only a few weeks of use. The quality is just not there for a handle that cost nearly 20 euro!

Share this post


Link to post
Eric Gilliand
Not dropped it yet but I do use it with the FLIQ pad and have noticed the rubber and channel have moved quite a bit after using the FLIQ. Don't get me wrong, I love this squeegee it is by far the best yet but I am a bit concerned with the movement of the channel and rubber after only a few weeks of use. The quality is just not there for a handle that cost nearly 20 euro!

Quality not there? Have to disagree. This handle is being asked to do many things that others don't and design and manufacture are nicely balanced. We all use different techniques. If you find handle is moving excessively why not put a bit of stop tape either side of the handle once it's centred. I used to do this with all my Wags because I hated the accursed screw through the channel.

Share this post


Link to post
Tim Osborne

Update on handle-

I contacted Moreman about the problem and they got me in contact with Robert Hatt AKA Polzn Blades and he said to check the spring. On the prototypes they used a different spring that is now on the Excelerators in production. Somehow I got a prototype spring in mine and was rusted and weak. Moreman had a new handle sent to me and it is fantastic. I am very impressed with Moreman and there customer support. I take back everything I said about the handle! This is a great handle and has save me loads of time and money.

Share this post


Link to post
keefo

How long until the pad starts dropping down fully if using in hand. I like the flow of the 10" so far but with the 14" 2.0 channel and Excel handle I tend to be leaving water from the middle. Having to use the old liquidator channel at the moment with the bent back clips. ac6f0ebf3b990795ccb9e49d5bfe1011.jpg

Share this post


Link to post
Guest Keithlons

I've been using my excelerator for one month now. I have a 10 and 14 inch. I saw a guy on YouTube who suggested putting electrical tape on the channel where you fit the handle to stop slip. I have tried this and have not hat a problem. By the way I was a wagtail user but find the excelerator the better squeegee. Great on a pole. And for fanning just had to slightly change technique.

Share this post


Link to post
keefo
I've been using my excelerator for one month now. I have a 10 and 14 inch. I saw a guy on YouTube who suggested putting electrical tape on the channel where you fit the handle to stop slip. I have tried this and have not hat a problem. By the way I was a wagtail user but find the excelerator the better squeegee. Great on a pole. And for fanning just had to slightly change technique.

Don't have a problem with channel/rubber slipping, just wondered how long it took for pad to flop down fully. I've heard it takes a bit of time to lose it's stiffness. Do you find it better on a pole or in hand.

Share this post


Link to post
Guest Keithlons

On a pole I put scrubber over the top of squeegee. In hand it's better underneath. I give up trying to flip it from underneath but it's not a big problem to me as I always use two squeegees. On YouTube I did see a guy put a rod through the scrubber and it seemed to work fine.

Share this post


Link to post
Eric Gilliand
How long until the pad starts dropping down fully if using in hand. I like the flow of the 10" so far but with the 14" 2.0 channel and Excel handle I tend to be leaving water from the middle. Having to use the old liquidator channel at the moment with the bent back clips. ac6f0ebf3b990795ccb9e49d5bfe1011.jpg

Pad will always be stiffer than the Wagtail but generally 2-3 days of heavy use. Remember the default position is top mount for pole work. I've taken the brand tag off mine (including the stitching of course because I find that adds another layer of stiffness to one end causing unevenness when dropped. Check your pad by pressing the bottom back towards the handle. Some of them will actually snap back out of the way because of the tightness between clips. This is optimum for under mounting.

Share this post


Link to post
keefo

Actually did a test last night with my old brass ettore channel on a troublesome window at home where you can see everything in rising sun and apart from a tiny part it was great. I've just done the Excelerator with just handle and channel whilst the sun still rising and quite a bit of arches.

Whichever rubber I put in I'm getting a cluster of lines together, approx 4 or 5 coming from 3-6cm from the end, on the inside of the glass.

Share this post


Link to post
Eric Gilliand

1. Are both clips housed correctly

2. Do you put the rubber in the channel separately ensuring that it is stretched evenly along the length of the channel. Spraying a bit of soap in the channel helps the rubber feed evenly.

3. You then snap handle on clean, square without distorting the rubber as you do so.

 

I'm not saying any of these is causing the issue. Just throwing some ideas out there for you. I'm at a loss because I've never had these problems with either V1 or V2 channels. The closest I've come is when one of my clips wasn't attached correctly and with a length of dodgy Razer 14" that had a distorted bulb meaning it wouldn't thread into the channel smoothly.

Share this post


Link to post
keefo
1. Are both clips housed correctly

2. Do you put the rubber in the channel separately ensuring that it is stretched evenly along the length of the channel. Spraying a bit of soap in the channel helps the rubber feed evenly.

3. You then snap handle on clean, square without distorting the rubber as you do so.

 

I'm not saying any of these is causing the issue. Just throwing some ideas out there for you. I'm at a loss because I've never had these problems with either V1 or V2 channels. The closest I've come is when one of my clips wasn't attached correctly and with a length of dodgy Razer 14" that had a distorted bulb meaning it wouldn't thread into the channel smoothly.

It's with the old 14" channel as well Eric and old clips, but happens with V2. I don't know what suddenly happened. I'm wondering if other people don't go to the nth degree like me to see them. I can only really see them in the rising or setting sun as mentioned previously. Sometimes i have to crouch down, put my hand stretched out in front of me to block sun then look above my hand and you can see them. I can't see them in sunlight between say 9am-3pm.t I did find in comparison with the Ettore that when I'm slightly out of the soap area making a pass compared to liquidator it's was a lot smoother. Yesterday morning job in a very sandy area was a nightmare. When i was cleaning the insides I could see them all on the outside and some inside. I do put the rubber in channel separately then just channel and snap handle shut.

Share this post


Link to post
keefo

Used old Moerman handle today and all good again, not sure if it's the flex in the excel handle. I'll use it for pole work.

This is what my window at home looks like once the rising sun goes and you wouldn't know.....it's just that low bloody sun.98ed434f82b4a86b2a09a0c3fef885b1.jpg

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.