Jump to content

Don't want to see ads? Become a subscribed member.

Ro problems


Guest Derbyshirecleaning

Recommended Posts

Guest Derbyshirecleaning

Last week I decided to take the week off and take the tank out of the van and waterproof the floor. The waterproofing went great!
 
But after having stripped the filters off the tank (I didn't remove them from their casing) and stored them inside, now ive put them back on the tank and my 40inch Ro filter doesn't seem to be working.
 
My tap water is 240ppm and the ro is bringing it down to 180ppm which makes the overall ppm 15 and the water pressure going into the tank is higher than I've ever seen.
 
Also the pressure on the waste isn't a high as it was. Please could someone help.
 
 
Sent using the Window Cleaning Forums mobile app
 
 


Link to comment

The end with the single port is the input from your prefilters. On the other side you have 2 ports. The one in the centre of the housing is the pure. The one to the side is your waste.

First thing to do is check those connections are correct.

 

 

Link to comment
Guest Derbyshirecleaning
The end with the single port is the input from your prefilters. On the other side you have 2 ports. The one in the centre of the housing is the pure. The one to the side is your waste.
First thing to do is check those connections are correct.
 
 

Thanks for the reply, yeps I've hooked it up wrong... Epic fail!. It has seemed to have ruined the RO filter, when I receive a replacement is there a right or wrong way to put it in? Thanks again

Sent using the Window Cleaning Forums mobile app

Link to comment

We have a champ housing so these are the instructions for this model. It will be the same procedure for any other housing.

 

You only need to remove the feed end housing to remove and replace the membrane.

 

Insert the membrane into the housing with the black brine seal at the feed end (ie feed the membrane in with
the brine seal end going in last). Push the membrane firmly to ensure it is fully inserted. Push in the end cap, again ensure it is fully inserted to reveal the holding ring groove. Replace the holding ring.

Link to comment
  • 2 weeks later...

Don't want to see ads? Become a subscribed member.


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Ad Blocker Detected

Please disable your ad blocker

Our forum relies on ads to pay for the servers and our time maintaining and running the forum.

Sadly running a forum like this is not free, and due to our popularity, we need servers that can handle the amount of traffic and resources our forum uses.

 

If you do not wish to see ads on our site, please consider supporting the forum with a membership subscription.

 

Accept