Jump to content
Welcome guest/lurker! Read more... ×


Recommended Posts

Advice needed please!

 

Running a trolley system and lately 100degree fan jets are spraying out like pencil jets

Thought there was a problem with jets so put new ones in!

Problem on going so opened up pole and seen a kink in the pole hose so sorted that out

(Cut out the kink)

Using reinforced pole hose

Bloody heavy as hell!

Checked the trolley filter is clean!

Even tried using pencil jets as I have that option on the pole doesn’t seem enuf power as use to be and my setting are on ‘40’ if that helps!

 

Any idea what the problem can be fellas

Would appreciate any help

 

Thanks

 

 

Sent using the Window Cleaning Forums mobile app

Share this post


Link to post
 

Might be a piece of grit or something in one of the hoses, i would also disconnect all the brush fittings and flush it all through in the opposite direction.

Every so often i somehow get a blockage at the brush head which interferes with the spray.   

Share this post


Link to post

Battery dying maybe?

What's the flow like when you disconnect the brush? You need good flow and good pressure for fans to work well. If you have a blockage or your battery is dying your fans are not going to work well

Share this post


Link to post
Battery dying maybe?
What's the flow like when you disconnect the brush? You need good flow and good pressure for fans to work well. If you have a blockage or your battery is dying your fans are not going to work well


Pressure seems fine also when I connected the pencil jets they seemed fine but I’ll check again


Sent using the Window Cleaning Forums mobile app

From listening to you fellas
Gotta feeling maybe a blockage somewhere


Sent from my iPhone using Window Cleaning Forums

Might be a piece of grit or something in one of the hoses, i would also disconnect all the brush fittings and flush it all through in the opposite direction.
Every so often i somehow get a blockage at the brush head which interferes with the spray.   


Will try that too mate


Sent using the Window Cleaning Forums mobile app

Share this post


Link to post

Thank you fellas for thee input!

Think it was just air and a minor leak which is sorted!


Sent from my iPhone using Window Cleaning Forums

Share this post


Link to post

The only problem I've had with fans, particularly Gardiners black ones is their tendency to block with tiny peices of debris occasionally.  This has largely been sorted by fitting a good strainer in the feed to the pump and by making sure that the hose ends are free of grit before connecting up as sometimes grit can find it's way in there.

Share this post


Link to post

Best Way way I have found to clear the 100 degree fan jets is disconnect the blocked jet from the JG tee piece and suck the pipe works every time not very pleasant but works.

Share this post


Link to post

Im pleased im not the only one who's jets get blocked

Do all your jets spray out equally on a straight line ? Mine are all over the shop , i have even trimmed the bristles on the brush to no avail. 

Share this post


Link to post


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.