Jump to content

waterworks hd reel dead!


Hiace Nostalgia

Recommended Posts

Hiace Nostalgia

afternoon  all. just had my 3 month old waterworks electric reel die on me- nothing happening on the button at all. was reeling in, it started going slow as the hose was bunched up round a corner then suddenly died. 40a fuse seems fine, checked all other connectors. does it have some kind of safety cut out when under prolonged heavy load? any help much appreciated!👍

Link to post
Hiace Nostalgia

thanks @Pjj manage to locate the issue- the yellow button had broken, so just swapped the wires to the bottom "spare" button and we were back in business! are these a weak point? I've never heard of problems with before personally?

  • Like 2
Link to post
20 minutes ago, Hiace Nostalgia said:

thanks @Pjj manage to locate the issue- the yellow button had broken, so just swapped the wires to the bottom "spare" button and we were back in business! are these a weak point? I've never heard of problems with before personally?

Not that Ime aware of I know some have had new reels delivered with loose wires inside the box but that’s about it 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.