Jump to content

Algoclear on plastic conny roof.


Recommended Posts

Good Evening everyone 

Have any of you got overspray on a plastic conservatory roof before? 

The customer called me today saying there is a haze on a roof panel after a roof clean I carried out last week. For the clean I used Algoclear pro. 
 

I went back and gave the roof panel a good clean with just pure water and some of the haze went but not all. 
 

Has anyone come across this before and if so how did you solve the issue?

 

Thanks 
 

 

Link to post
scottish cleaning service

I only use degreaser and hotwater so never had any problem. I would just re-clean it with ubik, virosol or degreaser. I guess you won't use Algoclear again.

Link to post
19 minutes ago, scottish cleaning service said:

I only use degreaser and hotwater so never had any problem. I would just re-clean it with ubik, virosol or degreaser. I guess you won't use Algoclear again.

Sorry I should have explained better. I treated the customers house roof with Algoclear after scraping it and I think some overspray went onto the plastic conservatory roof below which may have caused this haze. 
 

Ill give it a go with degreaser in the morning though. 

  • Like 1
Link to post
15 minutes ago, Lee89 said:

Sorry I should have explained better. I treated the customers house roof with Algoclear after scraping it and I think some overspray went onto the plastic conservatory roof below which may have caused this haze. 
 

Ill give it a go with degreaser in the morning though. 

I don’t think algo clear  Pro will hurt plastic roofs , we have used loads of it and never had any problems, if it’s a plastic roof it will probably be condensation in the air gap which you won’t be able to do anything about and won’t have caused it either .

Link to post
1 minute ago, Pjj said:

I don’t think algo clear  Pro will hurt plastic roofs , we have used loads of it and never had any problems, if it’s a plastic roof it will probably be condensation in the air gap which you won’t be able to do anything about and won’t have caused it either .

Thanks Pjj

I did have my suspicions wether the haze was there before the Algoclear was used but unfortunately I can’t prove it. 
 

 

Link to post
  • 2 weeks later...
On 20/07/2020 at 21:42, Lee89 said:

Thanks Pjj

I did have my suspicions wether the haze was there before the Algoclear was used but unfortunately I can’t prove it. 
 

 

It’s up to the customer to prove to you it wasn’t there before, not the contrary. It’s possible that the customer wants you to fix a problem that was already there.

Some sneaky ones out there 😛

Link to post
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.