Jump to content






Before posting a new topic please use the search feature. Duplicate posts may be removed or merged with others.

Start new topic


Cookie

Power UP HD Reel. Does this look normal?

Recommended Posts

Cookie

I have recently purchased a Power Up HD Reel from Waterworks. A great piece of kit and I think I'm already reaping the benefits of not having to wind in manually.

However the spindle does seem to wobble where it connects to the pump/tank. I have contacted Waterworks, having sent them a copy of this video & am waiting to hear back. Does this look normal to you? Any feedback appreciated...

https://youtu.be/nqWbQeS97fE

Share this post


Link to post
Suhrly

Mine from Pure Freedom does that. I just can't remember if it was doing it from the start of when I got it 7 months ago 🙄

Share this post


Link to post

Advertisement


 
spruce
11 hours ago, Cookie said:

I have recently purchased a Power Up HD Reel from Waterworks. A great piece of kit and I think I'm already reaping the benefits of not having to wind in manually.

However the spindle does seem to wobble where it connects to the pump/tank. I have contacted Waterworks, having sent them a copy of this video & am waiting to hear back. Does this look normal to you? Any feedback appreciated...

https://youtu.be/nqWbQeS97fE

 

I would wait for the response from the supplier. Further investigation would be needed to determine if it was a bent center shaft or a poorly made swivel. I personally wouldn't be happy about it but it depends on what the manufacturer says is 'commercially acceptable.' I would remove the swivel and rotate the drum to see if the center hub runs true or not. If it does run true then the problem is the swivel.

Share this post


Link to post
Pjj

I personally wouldn’t accept that on a reel costing what it does , my manual reels that cost £150 each certainty don’t do that so a good quality electric reel certainly shouldn’t 

Share this post


Link to post
Cookie
1 hour ago, spruce said:

 

I would wait for the response from the supplier. Further investigation would be needed to determine if it was a bent center shaft or a poorly made swivel. I personally wouldn't be happy about it but it depends on what the manufacturer says is 'commercially acceptable.' I would remove the swivel and rotate the drum to see if the center hub runs true or not. If it does run true then the problem is the swivel.

 

Thanks all for your replies. I'll wait for their feedback before I remove anything (I don't want to invalidate the warranty).

 

If it is the swivel that makes things a bit easier. As part of this reel changeover I've also moved things around in the van and  re-configured the system - since I've moved from 8mm to 6mm reel hose and gone tubeless at the same time. Apart from this swivel 'wobble' everything has worked out OK.

Share this post


Link to post
jack b

Just checked mine Cookie, it does not do that ,(as per video) just turns normally, for what its worth. I have found them v helpful with a minor issue I had re replacement washers.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.