Jump to content

Archived

This topic is now archived and is closed to further replies.

Ben23

Lance stuck on connector, any suggestions?

Recommended Posts

Ben23

Evening all. Im usually done for the season by now but have a last job to squeeze in before i close it up for the winter, problem is that the connection at the end of the hose (quick release one IE a collar around ball bearings that should just clip on and unclip easily) is stuck fast on the lance, ive tried everything I can think of but it wont budge and will mean im stuck using the lance on a driveway that will only take me an hour with the FSC. any help with this would be most appreciated

 

Cheers

 

Ben

Share this post


Link to post
Pjj
1 hour ago, Ben23 said:

Evening all. Im usually done for the season by now but have a last job to squeeze in before i close it up for the winter, problem is that the connection at the end of the hose (quick release one IE a collar around ball bearings that should just clip on and unclip easily) is stuck fast on the lance, ive tried everything I can think of but it wont budge and will mean im stuck using the lance on a driveway that will only take me an hour with the FSC. any help with this would be most appreciated

 

Cheers

 

Ben

Have you tried wd40 ?  Let it soak for a few muinets , Or a bit if heat with hot air gun 

Share this post


Link to post
Ben23

Cheers for the replies guys, I tried the WD40 and it didnt do the trick on its own, tapped the collar down with a hammer in the end and it sorted itself out, problem is that while working today the seal blew and so I was forced to take the connector off and screw the hose directly into the FSC, worked fine but its pretty inconvenient  having to take spanners to the equipment everytime I want to change over, going to order a new connector I think as this ones been dicey since I bought the hose a couple of months ago. the last one lasted 3 years before I had any issue but that was a brass fitting (not sure if/how that made a difference) this one was stainless and it arrived loose then has been nothing but problems from then on.....Still its not all bad news, got my last clean of the season done and I'll sort the new bits out over the winter.

 

Thanks again for the help, much appreciated

 

Ben

Share this post


Link to post
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.