Jump to content

Booster pump pressure issue


Baldmonkey

Recommended Posts

Hi guys, I know someone's going to know the answer to this, nothing on the forum that I have managed to find. 

I'm running a 4040 with an axeon hf5 membrane, booster pump is a brand new wortex jx80.. Can only seem to build up 60 psi and that's when the waste is virtually closed (don't worry only did this for a few seconds then opened up full throttle again)

Anway is the too small for the membrane, or do I need a pressure building valve or tank, thanks for the help 👍

Link to post
9 minutes ago, Baldmonkey said:

Anway is the too small for the membrane, or do I need a pressure building valve or tank, thanks for the help 👍

Is your question is the pressure too small?

if so

hf5 will run as low as 30psi in real world. Ran one for 3 years on 37-40psi down to 13ppm from 300. 
And was slow with pre filter filter changes.

axeon hf5. The Honda c90 of the membrane world. Nails!

  • Like 2
Link to post
1 minute ago, Omega said:

Is your question is the pressure too small?

if so

hf5 will run as low as 30psi in real world. Ran one for 3 years on 37-40psi down to 13ppm from 300. 
And was slow with pre filter filter changes.

axeon hf5. The Honda c90 of the membrane world. Nails!

hi omega, thanks for the reply. really want it to run at its suggested minimum pressure of 80psi, just cant get it up there using my usual method of balancing the waste output, thanks

 

Link to post

The wortex jx80 says it does 50l/min but a max of 38m head (125ft)  which is about 55psi. So looks like it's not man enough.

But don't take my word for it as I may have the calcs wrong?

Link to post
1 hour ago, doug atkinson said:

Sounds like the pump is too small. How many litres a minute does it do.

 

1 hour ago, ched999uk said:

The wortex jx80 says it does 50l/min but a max of 38m head (125ft)  which is about 55psi. So looks like it's not man enough.

But don't take my word for it as I may have the calcs wrong?

 

10 minutes ago, doug atkinson said:

Have had a look at the spec pressure is too low. 

Yep looks like I've got a new pump for the pond 😂😂 still only paid £60 for it and it's brand new

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.